summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-20 19:08:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-20 19:38:42 +0200
commit5c30eb61d74034a1b7c188b8d7be7df0b926025f (patch)
tree01cca0f80d1acdd6aaf1df69c6cd94c41619678d /gnu/packages/web.scm
parent47253d4837f72dc912f08bdbcd657d968e6ef8ce (diff)
downloadguix-5c30eb61d74034a1b7c188b8d7be7df0b926025f.tar.gz
gnu: http-parser: Fix build [and guix pull] on armhf-linux.
* gnu/packages/web.scm (http-parser)[source]: Add patch.
* gnu/packages/patches/http-parser-fix-assertion-on-armhf.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 285d2b3bf0..1851590628 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5917,24 +5917,26 @@ into your tests.  It automatically starts up a HTTP server in a separate thread
               (method git-fetch)
               (uri (git-reference (url home-page)
                                   (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "1vda4dp75pjf5fcph73sy0ifm3xrssrmf927qd1x8g3q46z0cv6c"))
               (file-name (git-file-name name version))
               (patches
-               ;; When parsing URLs, treat an empty port (eg
-               ;; `http://hostname:/`) as if it were unspecified.  This patch is
-               ;; applied to Fedora's http-parser and to libgit2's bundled version.
-               (list
+               (cons*
                 (origin
+                  ;; Treat an empty port (e.g. `http://hostname:/`) when parsing
+                  ;; URLs as if no port were specified.  This patch is applied
+                  ;; to Fedora's http-parser and to libgit2's bundled version.
                   (method url-fetch)
                   (uri (string-append
-                         "https://src.fedoraproject.org/rpms/http-parser/raw/"
-                         "e89b4c4e2874c19079a5a1a2d2ccc61b551aa289/"
-                         "f/0001-url-treat-empty-port-as-default.patch"))
+                        "https://src.fedoraproject.org/rpms/http-parser/raw/"
+                        "e89b4c4e2874c19079a5a1a2d2ccc61b551aa289/"
+                        "f/0001-url-treat-empty-port-as-default.patch"))
                   (sha256
                    (base32
-                    "0pbxf2nq9pcn299k2b2ls8ldghaqln9glnp79gi57mamx4iy0f6g")))))
-              (sha256
-               (base32
-                "1vda4dp75pjf5fcph73sy0ifm3xrssrmf927qd1x8g3q46z0cv6c"))))
+                    "0pbxf2nq9pcn299k2b2ls8ldghaqln9glnp79gi57mamx4iy0f6g")))
+                ;; A fix for <https://issues.guix.gnu.org/40604>.
+                (search-patches "http-parser-fix-assertion-on-armhf.patch")))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"