summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-24 16:36:13 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-24 16:36:13 +0200
commit23212bf9e68d53c18343149eeea9c436ab6f4f52 (patch)
tree2d94b0edd4d4807c1a2c478eb1e8207d364a5729 /gnu/packages/web.scm
parente2f24597a9da51ba6739f4fdb44217b41a8bab84 (diff)
downloadguix-23212bf9e68d53c18343149eeea9c436ab6f4f52.tar.gz
gnu: perl: Work around "dotless @INC" build issues.
* gnu/packages/perl.scm (perl-task-weaken)[arguments]: New field.
(perl-unicode-normalize): Likewise.
* gnu/packages/web.scm (perl-http-server-simple)[arguments]: Add #:phases.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 69a979eaef..e9c5021617 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2515,7 +2515,16 @@ environment from an HTTP::Request.")
     (arguments
      ;; See the discussion of a related tests issue at
      ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00346.html
-     `(#:tests? #f))
+     `(#:tests? #f
+
+       #:phases (modify-phases %standard-phases
+                   (add-before 'configure 'set-search-path
+                     (lambda _
+                       ;; Work around "dotless @INC" build failure.
+                       (setenv "PERL5LIB"
+                               (string-append (getcwd) ":"
+                                              (getenv "PERL5LIB")))
+                       #t)))))
     (home-page "http://search.cpan.org/dist/HTTP-Server-Simple")
     (synopsis "Lightweight HTTP server")
     (description "HTTP::Server::Simple is a simple standalone HTTP daemon with