summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2022-03-07 13:47:46 +0100
committerJelle Licht <jlicht@fsfe.org>2022-03-07 13:47:46 +0100
commit98f58f7ae51c107637784358bbb6344b496ce379 (patch)
treeca3010ca0aa34cee434d5fc2f6c6221142b5ff30 /gnu/packages/web.scm
parent6c3c4f7088bb0aae953d25f2bbfdaae5129686f3 (diff)
downloadguix-98f58f7ae51c107637784358bbb6344b496ce379.tar.gz
gnu: Add siege.
* gnu/packages/web.scm (siege): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3faf5bb153..af1719e9bf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7883,6 +7883,36 @@ in mind.  It has features such as:
 @end itemize")
     (license license:isc)))
 
+(define-public siege
+  (package
+    (name "siege")
+    (version "4.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.joedog.org/siege/siege-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1a74py0ib1gr3znv9ah5acw67ngl08b14dbc90ww9clvgdr2ag0l"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags (list (string-append "--with-zlib="
+                                              (assoc-ref %build-inputs "zlib"))
+                               (string-append "--with-ssl="
+                                              (assoc-ref %build-inputs
+                                                         "openssl")))))
+    (inputs (list openssl zlib))
+    (home-page "https://www.joedog.org/siege-home/")
+    (synopsis "HTTP/FTP load tester and benchmarking utility")
+    (description
+     "Siege is a multi-threaded HTTP/FTP load tester and benchmarking utility.  It
+can stress test a single URL with a user defined number of simulated users, or
+it can read many URLs into memory and stress them simultaneously.  The program
+reports the total number of hits recorded, bytes transferred, response time,
+concurrency, and return status.")
+    ;; GPLv3+ with OpenSSL linking exception.
+    (license license:gpl3+)))
+
 (define-public gmnisrv
   (package
     (name "gmnisrv")