summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
commit3a4de6b2d2fdb515c8186cbceab4259aab91cadf (patch)
tree7eaa4544ba397ce3493c26679ee2eafe76f8e448 /gnu/packages/web.scm
parentcaaf1933a453e7f3f8d7444f2c97dac3f8a93e1c (diff)
downloadguix-3a4de6b2d2fdb515c8186cbceab4259aab91cadf.tar.gz
gnu: Add missing quotes in phase names passed to 'modify-phases'.
This is a followup to f8503e2.

* gnu/packages/gnome.scm (glib-networking): Add missing quotes before
  phase names passed to 'modify-phases'.
  (libsoup): Likewise.
  (gnome-terminal): Likewise.
  (colord): Likewise.
  (geoclue): Likewise.
* gnu/packages/gtk.scm (at-spi2-core, at-spi2-atk): Likewise.
* gnu/packages/haskell.scm (ghc-network): Likewise.
* gnu/packages/imagemagick.scm (perl-image-magick): Likewise.
* gnu/packages/video.scm (aalib): Likewise.
* gnu/packages/web.scm (nginx): Likewise.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 374642862a..c6a3938546 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -109,11 +109,11 @@ and its related documentation.")
      `(#:tests? #f                      ; no test target
        #:phases
        (modify-phases %standard-phases
-         (add-before configure patch-/bin/sh
+         (add-before 'configure 'patch-/bin/sh
            (lambda _
              (substitute* "auto/feature"
                (("/bin/sh") (which "bash")))))
-         (replace configure
+         (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((flags
                     (list (string-append "--prefix=" (assoc-ref outputs "out"))
@@ -138,7 +138,7 @@ and its related documentation.")
                (format #t "environment variable `CC' set to `gcc'~%")
                (format #t "configure flags: ~s~%" flags)
                (zero? (apply system* "./configure" flags)))))
-         (add-after install fix-root-dirs
+         (add-after 'install 'fix-root-dirs
            (lambda* (#:key outputs #:allow-other-keys)
              ;; 'make install' puts things in strange places, so we need to
              ;; clean it up ourselves.