summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 06:04:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-29 06:08:18 +0100
commite00d5b6bbf38a9d95164c07b82f615d439f2bd6a (patch)
treec48bb19b0f43733a303d8a54bc4dd97ef52587f9 /gnu/packages/web.scm
parent73dd06546a80d3465d3afe8f6b256d6e8d681cfa (diff)
downloadguix-e00d5b6bbf38a9d95164c07b82f615d439f2bd6a.tar.gz
gnu: xinetd: Update to 2.3.15.4 [fix build].
* gnu/packages/web.scm (xinetd): Update to 2.3.15.4.
[source]: Switch to openSUSE (and Debian) maintenance fork.
Remove obsolete patches.
[native-inputs]: Add automake, autoconf, libtool, and pkg-config.
[home-page]: Update.
* gnu/packages/patches/xinetd-CVE-2013-4342.patch,
gnu/packages/patches/xinetd-fix-fd-leak.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e2ca9de9e4..31eff55d39 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5329,25 +5329,27 @@ additional capabilities.")
 (define-public xinetd
   (package
     (name "xinetd")
-    (version "2.3.15")
+    ;; This is the maintenance fork currently used by openSUSE and Debian.
+    (version "2.3.15.4")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/xinetd-org/xinetd.git")
-             (commit (string-append "xinetd-"
-                                    (string-join (string-split version #\.)
-                                                 "-")))))
+             (url "https://github.com/openSUSE/xinetd.git")
+             (commit version)))
        (file-name (git-file-name name version))
-       (patches (search-patches "xinetd-CVE-2013-4342.patch"
-                                "xinetd-fix-fd-leak.patch"))
        (sha256
-        (base32 "0wjai6qagcgxpa1khh639ih7kswgkryc7ll1i4hxhs29sc7irdcn"))))
+        (base32 "0lrp3lcj6azhjplwxws2rx40bkyp6i6bp7n77ndcisb7ninad30q"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--with-loadavg")
        #:tests? #f))                    ; no tests
-    (home-page "https://github.com/xinetd-org/xinetd")
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/openSUSE/xinetd")
     (synopsis "Internet services daemon")
     (description "@code{xinetd}, a more secure replacement for @code{inetd},
 listens for incoming requests over a network and launches the appropriate