summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-30 18:16:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-31 00:43:18 +0100
commit31afa654c58cd7aa8bd11a771fa6eabcd766d443 (patch)
tree4c44eb360061f793a692463231f075a12218901e /gnu/packages/web.scm
parentc3f146e79aca0efec5c0cbbf4e39c79e09268c15 (diff)
downloadguix-31afa654c58cd7aa8bd11a771fa6eabcd766d443.tar.gz
gnu: netsurf: Curb overzealous substitution.
* gnu/packages/web.scm (netsurf)[arguments]: Don't enforce Americanisms.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a0f46e3ee6..d3ab28bcfc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5028,21 +5028,20 @@ w3c webidl files and a binding configuration file.")
          (delete 'configure)
          (add-after 'build 'adjust-welcome
            (lambda _
-             ;; First, fix some unended tags and simple substitutions
              (substitute* "frontends/gtk/res/welcome.html"
+             ;; Close some XHTML tags.
                (("<(img|input)([^>]*)>" _ tag contents)
                 (string-append "<" tag contents " />"))
-               (("Licence") "License") ;prefer GNU spelling
+               ;; Increase freedom.
                ((" open source") ", free software")
-               (("web&nbsp;site") "website")
-               ;; Prefer privacy-respecting default search engine
+               ;; Prefer a more privacy-respecting default search engine.
                (("www.google.co.uk") "www.duckduckgo.com/html")
                (("Google Search") "DuckDuckGo Search")
                (("name=\"btnG\"") ""))
-             ;; Remove default links so it doesn't seem we're endorsing them
+             ;; Remove default links so it doesn't seem we're endorsing them.
              (with-atomic-file-replacement "frontends/gtk/res/welcome.html"
                (lambda (in out)
-                 ;; Leave the DOCTYPE header as is
+                 ;; Leave the DOCTYPE header as is.
                  (display (read-line in 'concat) out)
                  (sxml->xml
                   (let rec ((sxml (xml->sxml in)))