summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-11-21 21:26:41 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-11-21 21:26:41 +0100
commitddbc3a6f4ca2605d8102aa659389300f97d715ac (patch)
tree5cf6f1bd7f1a940be607a08c9620e028f63108c5 /gnu/packages/web.scm
parentf33a977706eb2f6dbbce8a515a4f4963a0f0579d (diff)
downloadguix-ddbc3a6f4ca2605d8102aa659389300f97d715ac.tar.gz
gnu: nghttp2: Resurrect cross-building.
* gnu/packages/web.scm (nghttp2)[arguments]: Add "--disable-python-bindings"
when cross-building.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ecb6d68cc1..48cbf736ba 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -40,7 +40,7 @@
 ;;; Copyright © 2019, 2020 Florian Pelz <pelzflorian@pelzflorian.de>
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -7630,7 +7630,10 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
              "--enable-app"             ; build all the tools
              "--enable-hpack-tools"     ; ...all the tools
              "--disable-examples"
-             "--disable-static")        ; don't bother building .a files
+             "--disable-static"         ; don't bother building .a files
+             ,@(if (%current-target-system)
+                   '("--disable-python-bindings")
+                   '()))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'break-circular-reference