summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-12-14 12:34:59 -0600
committerAlex Griffin <a@ajgrf.com>2019-12-14 13:22:54 -0600
commitd900e1f675d9332bc585ced375d7cc1478b10b21 (patch)
tree2260dadbd62bfff4aa694b078584f820515a808f /gnu/packages/web.scm
parente9d8dee6c3d6e2ddff74841a3ab3a2ba2816bf27 (diff)
downloadguix-d900e1f675d9332bc585ced375d7cc1478b10b21.tar.gz
gnu: Add htmlcxx.
* gnu/packages/web.scm (htmlcxx): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 749bc06fa9..0536f3089d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7011,3 +7011,36 @@ endpoint that will be used to trigger the task.  Poussetaches makes HTTP
 requests with the registered payload until the right status code is
 returned.")
     (license license:isc)))
+
+(define-public htmlcxx
+  (package
+    (name "htmlcxx")
+    (version "0.87")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "mirror://sourceforge/htmlcxx/v"
+                       version "/htmlcxx-" version ".tar.gz"))
+       (sha256
+        (base32 "1j3mzjlczjrk4ahc43s6kzpvzypzjmqz4sillnca5yadrwwgjf2x"))))
+    (build-system gnu-build-system)
+    (home-page "http://htmlcxx.sourceforge.net/")
+    (synopsis "Simple non-validating CSS1 and HTML parser for C++")
+    (description "htmlcxx is a simple non-validating CSS1 and HTML parser for
+C++.  Although there are several other HTML parsers available, htmlcxx has some
+characteristics that make it unique:
+@itemize
+@item STL like navigation of DOM tree, using excelent's tree.hh library from
+Kasper Peeters
+@item It is possible to reproduce exactly, character by character, the original
+document from the parse tree
+@item Bundled CSS parser
+@item Optional parsing of attributes
+@item C++ code that looks like C++ (not so true anymore)
+@item Offsets of tags/elements in the original document are stored in the nodes
+of the DOM tree
+@end itemize")
+    (license (list license:lgpl2.0
+                   license:gpl2
+                   license:asl2.0))))