summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 22:12:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:33 +0200
commit9ef958d8a2437f529a36375504eb4e34c9dceebe (patch)
treee906b834de60fbe185e2ed0e931d53ae1f89ccb1 /gnu/packages/web.scm
parentd5750d565f69ac78588f9ddb8709642e5f7de273 (diff)
downloadguix-9ef958d8a2437f529a36375504eb4e34c9dceebe.tar.gz
gnu: stunnel: Update to 5.60.
* gnu/packages/web.scm (stunnel): Update to 5.60.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d7bbd7489b..eae03932eb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5948,14 +5948,14 @@ tools like SSH (Secure Shell) to reach the outside world.")
 (define-public stunnel
   (package
   (name "stunnel")
-  (version "5.59")
+  (version "5.60")
   (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.stunnel.org/downloads/stunnel-"
                           version ".tar.gz"))
       (sha256
-       (base32 "17yf2n47j5hw2y9527mrkx3j7q9jk5vvg46m3hgp1wg8dggpcxqk"))))
+       (base32 "0zbqiydyz9dvfg3axh18a42v6j3xvnwjbd03kgm1z1i12mdpcpf4"))))
   (build-system gnu-build-system)
   (native-inputs
    ;; For tests.
@@ -5975,16 +5975,14 @@ tools like SSH (Secure Shell) to reach the outside world.")
                               "doc/Makefile.in"
                               "tools/Makefile.in")
              (("/doc/stunnel")
-              (string-append "/doc/" ,name "-" ,version)))
-           #t))
+              (string-append "/doc/" ,name "-" ,version)))))
        (add-before 'check 'patch-tests
          (lambda _
            (substitute* "tests/make_test"
              (("/bin/sh ")
               (string-append (which "sh") " ")))
-           ;; test requires networking
-           (delete-file "tests/recipes/055_socket_closed")
-           #t)))))
+           ;; This test requires networking.
+           (delete-file "tests/recipes/055_socket_closed"))))))
   (home-page "https://www.stunnel.org")
   (synopsis "TLS proxy for clients or servers")
   (description "Stunnel is a proxy designed to add TLS encryption