summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-28 17:52:21 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-29 09:37:14 +0100
commit2933cdf88e2b978da7d3ea995931946a6581a8e7 (patch)
treea42ee68e4a7984efe035f1cca6d7940c99cab2ab /gnu/packages/web.scm
parentcf47084a884c8cc76f81a0a396b84d56f8d01904 (diff)
downloadguix-2933cdf88e2b978da7d3ea995931946a6581a8e7.tar.gz
gnu: ikiwiki: Translate documentation.
* gnu/packages/web.scm (ikiwiki)[inputs]: Add po4a.
[arguments]<#:phases>[patch-Makefile]: Rename to...
[arguments]<#:phases>[patch-Makefiles]: ...this.  Add build environment
paths to the PERL5LIB environment variable that is used by the 'po2wiki'
script.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 15410f945b..6bb8257c8d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4840,10 +4840,13 @@ NetSurf project.")
                  "        addenv(\"PERL5LIB\", \""
                  (getenv "PERL5LIB")
                  "\");")))))
-         (add-after 'patch-source-shebangs 'patch-Makefile
+         (add-after 'patch-source-shebangs 'patch-Makefiles
            (lambda _
              (substitute* "Makefile.PL"
-               (("SYSCONFDIR\\?=") "SYSCONFDIR?=$(PREFIX)"))
+                          (("SYSCONFDIR\\?=") "SYSCONFDIR?=$(PREFIX)"))
+             (with-directory-excursion "po"
+               (substitute* "Makefile"
+                            (("PERL5LIB=") "PERL5LIB=${PERL5LIB}:")))
              #t))
          (add-before 'build 'set-modification-times
            ;; The wiki '--refresh' steps, which are executed during
@@ -4885,7 +4888,8 @@ NetSurf project.")
        ("perl-timedate" ,perl-timedate)
        ("perl-xml-sax" ,perl-xml-sax)
        ("perl-xml-simple" ,perl-xml-simple)
-       ("perl-xml-twig" ,perl-xml-twig)))
+       ("perl-xml-twig" ,perl-xml-twig)
+       ("po4a" ,po4a)))
     (propagated-inputs
      `(("perl-html-parser" ,perl-html-parser)
        ("perl-html-scrubber" ,perl-html-scrubber)