summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-04 23:02:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 00:20:39 -0400
commit69df14a02644cba77e1075bdc909058fc706edd3 (patch)
tree0983c4e83781e711294a2655fc2d6b155479d796 /gnu/packages/webkit.scm
parent7a03ab6ef7ccba59a1a773fd8768fff540625ace (diff)
downloadguix-69df14a02644cba77e1075bdc909058fc706edd3.tar.gz
gnu: gnome-online-accounts: Update to 3.45.2, remove "lib" output.
* gnu/packages/gnome.scm (gnome-online-accounts): Update to 3.45.2.
[build-system]: Use meson-build-system.
[glib-or-gtk?]: New argument.
[phases]{patch-libgoa-output}: Delete phase.
{disable-gtk-update-icon-cache}: New phase.
[native-inputs]: Add gettext-minimal.
[inputs]: Replace rest with rest-next; replace webkitgtk-with-libsoup2 with
webkitgtk.  Add gcr and mit-krb5.
(gnome-recipes): Adjust for the removed gnome-online-accounts output.
(gnome-music, gnome-online-miners, gnome-initial-setup): Likewise.
(libgdata, gnome-contacts, grilo-plugins, evolution-data-server)
(gnome-shell, gnome-todo, gnome-calendar, gnome-shell-extensions)
(gnome-calculator, gnome-latex): Likewise.
(gnome-online-accounts-3.44): New variable.
* gnu/packages/geo.scm (gnome-maps): Likewise.
* gnu/packages/webkit.scm: Update comment.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 6ef3eb456c..85aec6bbf3 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -277,11 +277,9 @@ propagated by default) such as @code{gst-plugins-good} and
                    license:bsd-2
                    license:bsd-3))))
 
-;;; Required by gnome-online-accounts as webkitgtk propagates libsoup 3, which
-;;; causes the build to fail.  Also required by e.g. emacs-next-pgtk,
-;;; emacs-xwidgets, and some other GNOME packages for webkit2gtk-4.0.  See
-;;; also the upstream tracker for libsoup 3:
-;;; https://gitlab.gnome.org/GNOME/libsoup/-/issues/218
+;;; Required by e.g. emacs-next-pgtk, emacs-xwidgets, and some other GNOME
+;;; packages for webkit2gtk-4.0.  See also the upstream tracker for libsoup 3:
+;;; https://gitlab.gnome.org/GNOME/libsoup/-/issues/218.
 (define-public webkitgtk-with-libsoup2
   (package/inherit webkitgtk
     (name "webkitgtk-with-libsoup2")