summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-26 18:39:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-27 12:26:17 +0200
commite5c65fb7372e10a2d6531d25f3b7d7c31679a21e (patch)
tree2cc875fad1fd66a6d8fe6ee92c5ba490b2398042 /gnu/packages/webkit.scm
parent85ead8f75151d6dc403fcb5a45a167e72c737217 (diff)
downloadguix-e5c65fb7372e10a2d6531d25f3b7d7c31679a21e.tar.gz
gnu: webkitgtk: Always use at least 2 make jobs.
Fixes <http://issues.guix.gnu.org/47964>.

* gnu/packages/webkit.scm (webkitgtk)[arguments]: Use at least -j2.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 083c8ccb08..74ffe92b84 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -260,6 +260,9 @@ acceleration in mind, leveraging common 3D graphics APIs for best performance.")
                           ;; now, we explicitly disable it to prevent an error
                           ;; at configuration time.
                           "-DUSE_GSTREAMER_GL=OFF")
+       #:make-flags
+       ;; Never build with unsupported -j1: https://issues.guix.gnu.org/47964#5
+       (list "-j" (number->string (max 2 (parallel-job-count))))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'configure-bubblewrap-store-directory