summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-26 16:40:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-27 18:57:37 +0200
commit689b44bc3fe50de86c8c8b8c2ac503b2e82d7975 (patch)
tree18cd42f603f97511fa76b0f890f2f25f83c5570b /gnu/packages/webkit.scm
parent9e0cb9d79d501f36740dade2c9a5d80f955ac2bc (diff)
downloadguix-689b44bc3fe50de86c8c8b8c2ac503b2e82d7975.tar.gz
gnu: WebKitGTK: Update to 2.26.1.
* gnu/packages/webkit.scm (webkitgtk-2.24): Rename to ...
(webkitgtk-2.26): ... this.  Update to 2.26.1.
[inputs]: Add BUBBLEWRAP, LIBSECCOMP, LIBWPE, WPEBACKEND-FDO, and XDG-DBUS-PROXY.
* gnu/packages/gnome.scm (eolie, epiphany)[inputs]: Adjust for changed
variable name.
* gnu/packages/web-browsers.scm (next-gtk-webkit)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 1eb8ae699d..4864495adf 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -48,6 +48,7 @@
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libreoffice)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -55,6 +56,7 @@
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages virtualization)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))
@@ -225,22 +227,27 @@ HTML/CSS applications to full-fledged web browsers.")
 ;; newer version of GCC than our default compiler, and this causes problems
 ;; when linked with C++ libraries built using our default compiler.  For now,
 ;; we use this newer webkitgtk only for selected packages, e.g. epiphany.
-(define-public webkitgtk-2.24
+(define-public webkitgtk-2.26
   (package/inherit webkitgtk
     (name "webkitgtk")
-    (version "2.24.4")
+    (version "2.26.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1n3x5g1z6rg9n1ssna7wi0z6zlprjm4wzk544v14wqi6q0lv2s46"))))
+                "0mfikjfjhwcnrxbzdyh3fl9bbs2azgbdnx8h5910h41b3n022jvb"))))
     (native-inputs
      `(("gcc" ,gcc-7)  ; webkitgtk-2.22 requires gcc-6 or newer
        ,@(package-native-inputs webkitgtk)))
     (inputs
-     `(("openjpeg" ,openjpeg)
+     `(("bubblewrap" ,bubblewrap)
+       ("libseccomp" ,libseccomp)
+       ("libwpe" ,libwpe)
+       ("openjpeg" ,openjpeg)
+       ("wpebackend-fdo" ,wpebackend-fdo)
+       ("xdg-dbus-proxy" ,xdg-dbus-proxy)
        ,@(package-inputs webkitgtk)))
     (arguments
      (substitute-keyword-arguments (package-arguments webkitgtk)