summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-16 08:31:16 +0100
committerLeo Famulari <leo@famulari.name>2022-01-29 16:39:56 -0500
commit07f45615c3600dd1405349a4f7c775394fbfd40d (patch)
treed5137e52437523f6d8a42aa8f4110a0c24416e66 /gnu/packages/webkit.scm
parentf0bc429a52ae414f1df2470e43e1fa9d0dd343a4 (diff)
downloadguix-07f45615c3600dd1405349a4f7c775394fbfd40d.tar.gz
gnu: wpewebkit: Update to 2.34.3 [security fixes].
This update fixes all the security issues fixed upstream between
versions 2.30.5 and 2.34.3:

https://webkitgtk.org/news.html

* gnu/packages/webkit.scm (wpewebkit): Update to 2.34.3.
[#:phases]: Add ‘patch-cmake’ phase to fix an error in the install directories
of the documentation.
[inputs]: Add lcms.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index d683d0aa5b..dfe780346e 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -124,7 +124,7 @@ engine that uses Wayland for graphics output.")
 (define-public wpewebkit
   (package
     (name "wpewebkit")
-    (version "2.30.5")
+    (version "2.34.3")
     (source
      (origin
        (method url-fetch)
@@ -132,7 +132,7 @@ engine that uses Wayland for graphics output.")
         (string-append "https://wpewebkit.org/releases/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "16imr0kmzhs7dz6jva9750xbsdz9v50playnagabajy30x7pymsb"))))
+        (base32 "1z20bza01ld4jvi0qx8xsl5y4czaniwpi8hxdjyirj1mrszy8pf3"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (arguments
@@ -162,6 +162,15 @@ engine that uses Wayland for graphics output.")
                                   "/xml/dtd/docbook/docbookx.dtd"))))
               (find-files "Source" "\\.sgml$"))
              #t))
+         (add-after 'unpack 'patch-cmake
+           (lambda _
+             (substitute* "Source/PlatformWPE.cmake"
+               (("(Documentation/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+                 all prefix)
+                (string-append prefix "${WPE_API_DOC_VERSION}"))
+               (("(html/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+                 all prefix)
+                (string-append prefix "${WPE_API_DOC_VERSION}")))))
          (add-after 'install 'move-doc-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -194,6 +203,7 @@ engine that uses Wayland for graphics output.")
        ("gst-plugins-base" ,gst-plugins-base)
        ("harfbuzz" ,harfbuzz)
        ("icu" ,icu4c)
+       ("lcms" ,lcms)
        ("libepoxy" ,libepoxy)
        ("libgcrypt" ,libgcrypt)
        ("libjpeg" ,libjpeg-turbo)