summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-13 15:00:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 14:44:00 +0100
commit72663b48221668f30b7bdcc502c299757a647156 (patch)
tree074d681bd18915fcf846f77fa3ebc9bba4505fc2 /gnu/packages/webkit.scm
parenteccaa8bf8deafbce7bf65b9d3b2822add00219c0 (diff)
downloadguix-72663b48221668f30b7bdcc502c299757a647156.tar.gz
gnu: WebKitGTK: Update to 2.24.0.
* gnu/packages/webkit.scm (webkitgtk-2.22): Rename to ...
(webkitgtk-2.24): ... this.  Update to 2.24.0.
[inputs]: Add OPENJPEG.
* gnu/packages/gnome.scm (eolie, epiphany)[inputs]: Adjust accordingly.
* gnu/packages/web-browsers.scm (next-gtk-webkit)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 7a4818609e..14c374dd3e 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -165,20 +165,23 @@ HTML/CSS applications to full-fledged web browsers.")
 ;; newer version of GCC than our default compiler, and this causes problems
 ;; when linked with C++ libraries built using our default compiler.  For now,
 ;; we use this newer webkitgtk only for selected packages, e.g. epiphany.
-(define-public webkitgtk-2.22
+(define-public webkitgtk-2.24
   (package/inherit webkitgtk
     (name "webkitgtk")
-    (version "2.22.7")
+    (version "2.24.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1zrhmz90sn30zgyflj4i86fsscws10xsi2kfs87nj2nd0pbggrjb"))))
+                "01s446lmjk7y8il4snjm32vpxws2rp4hmxrwm2swx0p47x8d2jif"))))
     (native-inputs
      `(("gcc" ,gcc-7)  ; webkitgtk-2.22 requires gcc-6 or newer
        ,@(package-native-inputs webkitgtk)))
+    (inputs
+     `(("openjpeg" ,openjpeg)
+       ,@(package-inputs webkitgtk)))
     (arguments
      (substitute-keyword-arguments (package-arguments webkitgtk)
        ((#:phases phases)