summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-05 13:58:36 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-05 14:11:54 +0100
commite8e2e18b84eb8842a59be9bf7d49bb672260ae3a (patch)
treef5b237e29d64ad6a2962af0251a39929e4a4d09c /gnu/packages/webkit.scm
parenta2ab82db9ab5d6db86762924d3016aed7c26c315 (diff)
downloadguix-e8e2e18b84eb8842a59be9bf7d49bb672260ae3a.tar.gz
gnu: Read 'C_INCLUDE_PATH' instead of 'CPATH'.
This is a followup to 009b53fd.

* gnu/packages/cmake.scm (cmake)[arguments]: Use (getenv
"C_INCLUDE_PATH") instead of (getenv "CPATH").
* gnu/packages/package-management.scm (rpm)[arguments]: Likewise.
* gnu/packages/video.scm (avidemux)[arguments]: Likewise.
* gnu/packages/webkit.scm (webkitgtk)[arguments]: Likewise.
* gnu/packages/cross-base.scm (cross-gcc-arguments): Likewise, and unset
'C_INCLUDE_PATH' and 'CPLUS_INCLUDE_PATH'.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index bb041b1935..d22aacd12f 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -80,7 +80,7 @@
             ;; that it will be in the same directory as gstreamer's header
             ;; files.
             (setenv "CPATH"
-                    (string-append (getenv "CPATH")
+                    (string-append (getenv "C_INCLUDE_PATH")
                                    ":"
                                    (assoc-ref inputs "gst-plugins-base")
                                    "/include/gstreamer-1.0")))))))