summary refs log tree commit diff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-06-12 12:53:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-06-12 12:58:33 +0300
commit08b00d384bb6af7a30103a34abf983b26c8715ba (patch)
tree8163edcf3508af0f673718c181c5c6e2a523b99e /gnu/packages/wget.scm
parentae6fa185af4f4fd81d933f229ea370034c26cfdf (diff)
downloadguix-08b00d384bb6af7a30103a34abf983b26c8715ba.tar.gz
gnu: wgetpaste: Add xclip to wrapper program list.
* gnu/packages/wget.scm (wgetpaste)[arguments]: Add xclip to list of
wrapper programs in custom 'wrap-program phase.
[inputs]: Add xclip.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 4940156db5..9a6436fe6b 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -37,6 +37,7 @@
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages xdisorg)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -123,11 +124,12 @@ in downloaded documents to relative links.")
                    ,(delete-duplicates
                      (map (lambda (command) (dirname (which command)))
                           (list "bash" "mktemp" "sed" "sort" "tee" "tr"
-                                "wget")))))
+                                "wget" "xclip")))))
                #t))))
        #:tests? #f))                    ; no test target
     (inputs
-     `(("wget" ,wget)))
+     `(("wget" ,wget)
+       ("xclip" ,xclip)))
     (home-page "http://wgetpaste.zlin.dk/")
     (synopsis "Script that automates pasting to a number of pastebin services")
     (description