summary refs log tree commit diff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-05 21:56:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-05 22:30:04 +0300
commitde3c03a47160dec355d9b19ad5ca210d90c15fd7 (patch)
tree4ca6dc05b5fc9530d812bbb269f1c61ab9efccf3 /gnu/packages/wget.scm
parentab6fe9d362046231ad6f46eccfd1ea2c9c80b401 (diff)
parentb8477cab7bccc4191ed3dfa3f149aec7917834d8 (diff)
downloadguix-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 146097f37c..1092237a03 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -77,15 +77,15 @@ in downloaded documents to relative links.")
 (define-public wgetpaste
   (package
     (name "wgetpaste")
-    (version "2.29")
+    (version "2.30")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
+        (uri (string-append "https://wgetpaste.zlin.dk/wgetpaste-"
                             version ".tar.bz2"))
         (sha256
-         (base32
-          "1rp0wxr3zy7y2xp3azaadfghrx7g0m138f9qg6icjxkkz4vj9r22"))))
+         (base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))
+        (patches (search-patches "wgetpaste-update-bpaste.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -95,12 +95,12 @@ in downloaded documents to relative links.")
        (modify-phases %standard-phases
          (delete 'configure)
          (delete 'build)
-         (add-after 'unpack 'remove-dead-paste-site
-           ;; This phase is adaped from the following patch:
-           ;; https://gitweb.gentoo.org/repo/gentoo.git/tree/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
+         (add-after 'unpack 'change-unfriendly-default
            (lambda _
              (substitute* "wgetpaste"
-               (("-bpaste") "-dpaste")) ; dpaste blocks tor users
+               ;; dpaste blocks Tor users.  Use a better default.
+               (("DEFAULT_SERVICE:-dpaste")
+                "DEFAULT_SERVICE-bpaste"))
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -129,7 +129,7 @@ in downloaded documents to relative links.")
     (inputs
      `(("wget" ,wget)
        ("xclip" ,xclip)))
-    (home-page "http://wgetpaste.zlin.dk/")
+    (home-page "https://wgetpaste.zlin.dk/")
     (synopsis "Script that automates pasting to a number of pastebin services")
     (description
      "@code{wgetpaste} is an extremely simple command-line interface to various