summary refs log tree commit diff
path: root/gnu/packages/which.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-04 17:21:21 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-04 17:23:27 +0100
commitce0614ddb0c9aae46fba677a46392de8039c7086 (patch)
tree352feb02941651b8714aca82f9f5cec59aa4a167 /gnu/packages/which.scm
parentf61e0e79006f1192c33622c4d564e95391763224 (diff)
downloadguix-ce0614ddb0c9aae46fba677a46392de8039c7086.tar.gz
gnu: Move 'which' to (gnu packages base).
* gnu/packages/which.scm: Remove.
* gnu-system.am (GNU_SYSTEM_MODULES): Remove it.
* gnu/packages/base.scm (which): New variable.
* gnu/packages/aspell.scm, gnu/packages/audio.scm,
  gnu/packages/autogen.scm, gnu/packages/cdrom.scm,
  gnu/packages/compression.scm, gnu/packages/datamash.scm,
  gnu/packages/games.scm, gnu/packages/glib.scm,
  gnu/packages/gnu-pw-mgr.scm, gnu/packages/gnutls.scm,
  gnu/packages/gps.scm, gnu/packages/guile.scm,
  gnu/packages/java.scm, gnu/packages/libevent.scm,
  gnu/packages/linux.scm, gnu/packages/lisp.scm,
  gnu/packages/node.scm, gnu/packages/ntp.scm,
  gnu/packages/orpheus.scm, gnu/packages/pciutils.scm,
  gnu/packages/python.scm, gnu/packages/qt.scm,
  gnu/packages/rsync.scm, gnu/packages/sawfish.scm,
  gnu/packages/scheme.scm, gnu/packages/ssh.scm,
  gnu/packages/statistics.scm, gnu/packages/texlive.scm,
  gnu/packages/wdiff.scm: Adjust accordingly.
Diffstat (limited to 'gnu/packages/which.scm')
-rw-r--r--gnu/packages/which.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/which.scm b/gnu/packages/which.scm
deleted file mode 100644
index df2f8e9976..0000000000
--- a/gnu/packages/which.scm
+++ /dev/null
@@ -1,44 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages which)
-  #:use-module (guix licenses)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public which
-  (package
-    (name "which")
-    (version "2.20")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/which/which-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "1y2p50zadb36izzh2zw4dm5hvdiydqf3qa88l8kav20dcmfbc5yl"))))
-    (build-system gnu-build-system)
-    (home-page "https://gnu.org/software/which/")
-    (synopsis "Find full path of shell commands")
-    (description
-     "The which program finds the location of executables in PATH, with a
-variety of options.  It is an alternative to the shell \"type\" built-in
-command.")
-    (license gpl3+))) ; some files are under GPLv2+