summary refs log tree commit diff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-03 10:52:46 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-03 11:01:51 +0100
commit0fa3d705d2f5821c9d116267fa9e2c6b3f69c846 (patch)
tree5d8d4cd818df2262b2f23e78bf4d4011d6c4a7aa /gnu/packages/wine.scm
parentea3510f8a7f0fe7add54d072b077236756ab3c54 (diff)
downloadguix-0fa3d705d2f5821c9d116267fa9e2c6b3f69c846.tar.gz
gnu: wine-staging: Add faudio support.
* gnu/packages/wine.scm (wine-staging)[inputs]: Add faudio.
[arguments]: Adjust patchinstall.sh to faudio.
* gnu/packages/wine.scm (wine64-staging)[arguments]: Adjust patchinstall.sh to
faudio.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 02561c5442..6d2d9ea09b 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -368,6 +368,7 @@ integrate Windows applications into your desktop.")
                (base32
                 "1d0gbwc8ll4mfxilw9j4vdzqlnracr6y8iss27nfg1qh0q7vbf9x"))))
     (inputs `(("autoconf" ,autoconf) ; for autoreconf
+              ("faudio" ,faudio)
               ("ffmpeg" ,ffmpeg)
               ("gtk+" ,gtk+)
               ("libva" ,libva)
@@ -406,7 +407,10 @@ integrate Windows applications into your desktop.")
                     (script (string-append (assoc-ref %build-inputs
                             "wine-staging-patchset-data")
                             "/share/wine-staging/patches/patchinstall.sh")))
-               (invoke script (string-append "DESTDIR=" ".") "--all")
+               ;; Exclude specific patches that conflict with FAudio.
+               (invoke script (string-append "DESTDIR=" ".") "--all" "-W"
+                       "xaudio2-revert" "-W" "xaudio2_CommitChanges" "-W"
+                       "xaudio2_7-WMA_support" "-W" "xaudio2_7-CreateFX-FXEcho")
                #t)))
          (add-after 'configure 'patch-dlopen-paths
            ;; Hardcode dlopened sonames to absolute paths.
@@ -482,7 +486,10 @@ integrated into the main branch.")
                     (script (string-append (assoc-ref %build-inputs
                             "wine-staging-patchset-data")
                             "/share/wine-staging/patches/patchinstall.sh")))
-               (invoke script (string-append "DESTDIR=" ".") "--all")
+               ;; Exclude specific patches that conflict with FAudio.
+               (invoke script (string-append "DESTDIR=" ".") "--all" "-W"
+                       "xaudio2-revert" "-W" "xaudio2_CommitChanges" "-W"
+                       "xaudio2_7-WMA_support" "-W" "xaudio2_7-CreateFX-FXEcho")
                #t)))
          (add-after 'install 'copy-wine32-binaries
            (lambda* (#:key outputs #:allow-other-keys)