summary refs log tree commit diff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/wine.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadguix-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 0327deaf24..8496eb3365 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -221,7 +221,7 @@ integrate Windows applications into your desktop.")
 (define-public wine-staging-patchset-data
   (package
    (name "wine-staging-patchset-data")
-   (version "3.3")
+   (version "3.4")
    (source
     (origin
      (method url-fetch)
@@ -230,7 +230,7 @@ integrate Windows applications into your desktop.")
      (file-name (string-append name "-" version ".zip"))
      (sha256
       (base32
-       "16l28vrhqn27kipqwms622jz1prfky8qkjb8pj747k3qjnm2k1g9"))))
+       "00yzh9bqs2rjgvk78xv3gfkbv4f2bkch9vb1ii4xh883f7wvkz93"))))
    (build-system trivial-build-system)
    (native-inputs
     `(("bash" ,bash)
@@ -270,15 +270,16 @@ integrate Windows applications into your desktop.")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://dl.winehq.org/wine/source/3.x/wine-" version
-                    ".tar.xz"))
+                    "https://dl.winehq.org/wine/source/"
+                    (version-major version) ".x"
+                    "/wine-" version ".tar.xz"))
               (file-name (string-append name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0cx31jsll7mxd9r7v0vpahajqwb6da6cpwybv06l5ydkgfrbv505"))))
+                "14wf7536rkmhav9ibbvhqqkfqmbk1dckhd2679i5scizr5x290x4"))))
     (inputs `(("autoconf" ,autoconf) ; for autoreconf
-              ("gtk+", gtk+)
-              ("libva", libva)
+              ("gtk+" ,gtk+)
+              ("libva" ,libva)
               ("python" ,python)
               ("sdl2" ,sdl2)
               ("util-linux" ,util-linux) ; for hexdump