summary refs log tree commit diff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/wine.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index d05b5c1b8c..d77d1070e1 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -75,7 +75,7 @@
 (define-public wine
   (package
     (name "wine")
-    (version "6.8")
+    (version "6.16")
     (source
      (origin
        (method url-fetch)
@@ -87,7 +87,7 @@
               (string-append "https://dl.winehq.org/wine/source/" dir
                              "wine-" version ".tar.xz")))
        (sha256
-        (base32 "1n7bd6kkhfgi23bz981qml3lajgvbs3ibqrc2mqjhhfqczg2shjv"))))
+        (base32 "1s7sz1rimax4kxij1ngkwnx4hcljwjq3q5gksz22k8cq1l2r4l39"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -194,7 +194,16 @@
                (substitute* "include/config.h"
                  (("(#define SONAME_.* )\"(.*)\"" _ defso soname)
                   (format #f "~a\"~a\"" defso (find-so soname))))
-               #t))))))
+               #t)))
+         (add-after 'patch-generated-file-shebangs 'patch-makefile
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "make" "Makefile") ; Makefile is first regenerated
+             (substitute* "Makefile"
+               (("-lntdll" id)
+                (string-append id
+                               " -Wl,-rpath=" (assoc-ref outputs "out")
+                               "/lib/wine32/wine/$(ARCH)-unix")))
+             #t)))))
     (home-page "https://www.winehq.org/")
     (synopsis "Implementation of the Windows API (32-bit only)")
     (description
@@ -254,6 +263,15 @@ integrate Windows applications into your desktop.")
                       #t)))))
              (_
               `()))
+         (add-after 'patch-generated-file-shebangs 'patch-makefile
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "make" "Makefile") ; Makefile is first regenerated
+             (substitute* "Makefile"
+               (("-lntdll" id)
+                (string-append id
+                               " -Wl,-rpath=" (assoc-ref outputs "out")
+                               "/lib/wine64/wine/$(ARCH)-unix")))
+             #t))
          (add-after 'install 'copy-wine32-binaries
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((wine32 (assoc-ref %build-inputs "wine"))