summary refs log tree commit diff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-22 23:35:54 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-04-22 23:40:21 +0200
commitc22204cf7bf12056c43e5da2fd99c95866143ddc (patch)
treeab1077aa3b12e9e90e909814c4a00c1e4d34bba2 /gnu/packages/wine.scm
parent6b99c5220729d8e9ea51e69f97dbe83c920792cd (diff)
downloadguix-c22204cf7bf12056c43e5da2fd99c95866143ddc.tar.gz
gnu: wine64-staging: copy wine32-staging libraries.
A similar phase has been added to wine64 since version 5.21 in order to fix
linkage issues of binaries copied from wine32.
See also <https://bugs.gnu.org/42342>.

* gnu/packages/wine.scm (wine64-staging)[#phases]: Add ‘copy-wine32-libraries’.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index a89d86b327..6f594bdc69 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -532,6 +532,13 @@ integrated into the main branch.")
                (copy-file (string-append wine32 "/bin/.wine-preloader-real")
                           (string-append out "/bin/wine-preloader"))
                #t)))
+         (add-after 'install 'copy-wine32-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((wine32 (assoc-ref %build-inputs "wine-staging"))
+                    (out (assoc-ref %outputs "out")))
+               (copy-recursively (string-append wine32 "/lib/wine32")
+                                 (string-append out "/lib/wine32"))
+               #t)))
          (add-after 'compress-documentation 'copy-wine32-manpage
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((wine32 (assoc-ref %build-inputs "wine-staging"))