summary refs log tree commit diff
path: root/gnu/packages/wireservice.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 22:41:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-09 23:55:42 +0100
commitef617dedd28ffa5c32cf9e0ee2482ce32aa195f4 (patch)
treee41ce431ba7a775cb8e415bc476678d3acecf3ae /gnu/packages/wireservice.scm
parent77dbc1c5377875e57577267e872b8c644bed0a43 (diff)
downloadguix-ef617dedd28ffa5c32cf9e0ee2482ce32aa195f4.tar.gz
gnu: csvkit: Update to 1.0.5.
* gnu/packages/wireservice.scm (csvkit): Update to 1.0.5.
[source]: Remove upstreamed patch.
* gnu/packages/patches/csvkit-fix-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/wireservice.scm')
-rw-r--r--gnu/packages/wireservice.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index eab76970f4..0d772b54d1 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -198,17 +199,16 @@ for xls and xlsx files support to all @code{agate.Table} instances.")))
 (define-public csvkit
   (package
     (name "csvkit")
-    (version "1.0.4")
+    (version "1.0.5")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "csvkit" version))
               (sha256
                (base32
-                "1830lb95rh1iyi3drlwxzb6y3pqkii0qiyzd40c1kvhvaf1s6lqk"))
-              (patches (search-patches "csvkit-fix-tests.patch"))))
+                "1ffmbzk4rxnl1yhqfl58v7kvl5m9cbvjm8v7xp4mvr00sgs91lvv"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-psycopg2" ,python-psycopg2) ;; Used to test PostgreSQL support.
+     `(("python-psycopg2" ,python-psycopg2) ; to test PostgreSQL support
        ("python-sphinx" ,python-sphinx)
        ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
     (inputs