summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2024-03-25 06:55:46 -0700
committerChristopher Baines <mail@cbaines.net>2024-03-27 12:32:34 +0000
commit8cc450e59a4c83fa39097964f62c2b2c84e0aee3 (patch)
tree985b2ef2558e666c53e257d48fc9fb500f18611e /gnu/packages/wm.scm
parent560062aaeabb485e7f53f8f5e6449b9a35aa9ca2 (diff)
downloadguix-8cc450e59a4c83fa39097964f62c2b2c84e0aee3.tar.gz
gnu: icewm: Update to 3.4.6.
* gnu/packages/wm.scm (icewm): Update to 3.4.6.
[arguments]: Remove the deletion of gmo files as they are not regenerated
correctly (see #68439).

Change-Id: Ieff1fc5417cfe164fa7886774e8855fd95248c8f
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f1e351bd04..2aaf9b0f66 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -797,7 +797,7 @@ desktop environment.")
 (define-public icewm
   (package
     (name "icewm")
-    (version "3.4.5")
+    (version "3.4.6")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -805,7 +805,7 @@ desktop environment.")
                     version "/icewm-" version ".tar.lz"))
               (sha256
                (base32
-                "1wd5k0whh2b43a72223cy19pwc29fhrhd2dnc61fha2y5ndgw6ld"))))
+                "1j4jd1fim12h8ry7jkx6y298kyn63pabih1m61rljbzvr3lyy1db"))))
     (build-system gnu-build-system)
     (native-inputs (list pkg-config))
     (inputs (list fontconfig
@@ -830,13 +830,6 @@ desktop environment.")
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
-               (add-after 'unpack 'remove-gmo-files
-                 ;; gmo files are generated from .po files
-                 ;; so remove them before build to make sure
-                 ;; they are re-generated if needed
-                 (lambda _
-                   (for-each delete-file
-                             (find-files "po" "\\.gmo$"))))
                (add-after 'unpack 'skip-failing-test
                  ;; strtest.cc tests failing due to $HOME and /etc setup
                  ;; difference under guix