summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/wm.scm
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
downloadguix-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar.gz
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage
release. Since packages are interdependent, do so in a single commit.

525 packages have been updated.

These packages have been removed, because they fail to build, have no
newer version available and no dependencies:

corrode
ghc-easytest
ghc-edisonapi
ghc-edisoncore
ghc-pandoc-types
ghc-regex-tdfa-text

These have been removed, because they are no longer required:

ghc-happy-1.19.9
ghc-prettyprinter-1.6
ghc-protolude-0.3

ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc
does not use them any more.

Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 672bd1ba8f..39d83336fd 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -712,13 +712,16 @@ desktop environment.")
     (build-system haskell-build-system)
     (inputs
      `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+       ("ghc-data-default"          ,ghc-data-default)
        ("ghc-quickcheck"            ,ghc-quickcheck)
        ("ghc-semigroups"            ,ghc-semigroups)
        ("ghc-setlocale"             ,ghc-setlocale)
        ("ghc-utf8-string"           ,ghc-utf8-string)
        ("ghc-x11"                   ,ghc-x11)))
     (arguments
-     `(#:phases
+     `(#:cabal-revision
+       ("1" "0yqh96qqphllr0zyz5j93cij5w2qvf39xxnrb52pz0qz3pywz9wd")
+       #:phases
        (modify-phases %standard-phases
          (add-after
           'install 'install-xsession
@@ -749,14 +752,14 @@ tiled on several screens.")
 (define-public xmobar
   (package
     (name "xmobar")
-    (version "0.34")
+    (version "0.39")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://hackage/package/xmobar/"
+              (uri (string-append "https://hackage.haskell.org/package/xmobar/"
                                   "xmobar-" version ".tar.gz"))
               (sha256
                (base32
-                "0x09xbz7y9ay0046j1xpr9jjk5jqivqi06vm3q6mhcrgc4y922rx"))))
+                "1k1n3ff0ikdmfq0mi8r2vpqg1iq6hsw1drvxps6k98rvvn87pws6"))))
     (build-system haskell-build-system)
     (native-inputs
      `(("ghc-hspec" ,ghc-hspec)
@@ -771,6 +774,7 @@ tiled on several screens.")
        ("ghc-http-types" ,ghc-http-types)
        ("ghc-iwlib" ,ghc-iwlib)
        ("ghc-libmpd" ,ghc-libmpd)
+       ("ghc-netlink" ,ghc-netlink)
        ("ghc-old-locale" ,ghc-old-locale)
        ("ghc-parsec-numbers" ,ghc-parsec-numbers)
        ("ghc-regex-compat" ,ghc-regex-compat)
@@ -832,6 +836,9 @@ particular, it displays commonly-chosen options before uncommon ones.")
        (sha256
         (base32 "1pddgkvnbww28wykncc7j0yb0lv15bk7xnnhdcbrwkxzw66w6wmd"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision
+       ("1" "0vimkby2gq6sgzxzbvz67caba609xqlv2ii2gi8a1cjrnn6ib011")))
     (propagated-inputs
      `(("ghc-old-time" ,ghc-old-time)
        ("ghc-random" ,ghc-random)