summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-05-09 15:37:49 +0800
committerLudovic Courtès <ludo@gnu.org>2023-05-21 01:09:58 +0200
commit9f5f9ebc92aa197301eff1808733e968813c0a2d (patch)
treea2878906f411ccf19bdb50e4906f1ea2ba7ba949 /gnu/packages/wm.scm
parent43510204c631e59b9a5a38e09caeea94d7a94de2 (diff)
downloadguix-9f5f9ebc92aa197301eff1808733e968813c0a2d.tar.gz
gnu: cagebreak: Update to 2.1.2.
* gnu/packages/wm.scm (cagebreak): Update to 2.1.2.
Explicitly disable tests and substitute "/usr/share/".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 24dda94dab..e760ff4aa2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2748,7 +2748,7 @@ shows a notification for the user on the screen.")
 (define-public cagebreak
   (package
     (name "cagebreak")
-    (version "2.0.1")
+    (version "2.1.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2757,16 +2757,21 @@ shows a notification for the user on the screen.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0fxfmxl7p63l07lqb83q5lx16hm0rixcidghx00gp08x2yrgr4x9"))))
+                "09ky8wili3ym8qi4dasckdcdcvn4g6ak08dg0yccnwmnlwxiyps6"))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dxwayland=true")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-data-dir
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("/etc/") (string-append (assoc-ref outputs "out") "/etc"))))))))
+     (list
+      #:configure-flags #~(list "-Dxwayland=true")
+      ;; XXX: Running cagebreak tests need more tools, such as: clang-format,
+      ;; shellcheck, git, gnupg ...
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-data-dir
+            (lambda _
+              (substitute* '("cagebreak.c" "meson.build")
+                (("/etc/") (string-append #$output "/etc/"))
+                (("/usr/share/") (string-append #$output "/usr/share/"))))))))
     (native-inputs (list pandoc pkg-config))
     (inputs (list libevdev pango wlroots))
     (home-page "https://github.com/project-repo/cagebreak")