summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-11-03 15:07:58 +0000
committerLudovic Courtès <ludo@gnu.org>2017-11-07 18:09:13 +0100
commitdb0164b21f82d3cb344e496874eeede9317e95ad (patch)
tree46a90491fcd82134ee025b761d91b393657a5a02 /gnu/packages/wm.scm
parent3eda8dd614fb1c1b44ce85fdaedcbe06245069ba (diff)
downloadguix-db0164b21f82d3cb344e496874eeede9317e95ad.tar.gz
gnu: awesome: Update to 4.2.
* gnu/packages/wm.scm (awesome): Update to 4.2.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c72e9a452c..09c10eaa0e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -541,7 +541,7 @@ experience.")
 (define-public awesome
   (package
     (name "awesome")
-    (version "4.0")
+    (version "4.2")
     (source
      (origin (method url-fetch)
              (uri (string-append
@@ -549,7 +549,7 @@ experience.")
                    "master/awesome-" version ".tar.xz"))
              (sha256
               (base32
-               "0czkcz67sab63gf5m2p2pgg05yinjx60hfb9rfyzdkkg28q9f02w"))
+               "0kwpbls9h1alxcmvxh5g9qb995fds5b2ngcr44w0ibazkyls2pdc"))
              (modules '((guix build utils)
                         (srfi srfi-19)))
              (snippet
@@ -599,6 +599,9 @@ experience.")
        ;; '--no-name' is used, which removes timestamps from gzip output.
        #:configure-flags '("-DCOMPRESS_MANPAGES=off")
 
+       ;; Building awesome in its source dir is no longer supported.
+       #:out-of-source? #t
+
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'xmlto-skip-validation