summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-09-18 00:04:17 +0000
committerChristopher Baines <mail@cbaines.net>2022-10-06 15:08:03 +0100
commit53e086c5c6ec9988f08bf7072c26030237dbd890 (patch)
tree820656d71c13258dd594b2de2d2b147632f3d372 /gnu/packages/wm.scm
parenteb5b104ca8a3d37cebb8ac6c93bdd0a0447db2b2 (diff)
downloadguix-53e086c5c6ec9988f08bf7072c26030237dbd890.tar.gz
gnu: Add waybar-cpu-histogram.
* gnu/packages/wm.scm (waybar-cpu-histogram): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5699e42540..af406ed2ed 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -57,6 +57,7 @@
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
 ;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
+;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1753,6 +1754,34 @@ display a clock or apply image manipulation techniques to the background image."
 Wlroots based compositors.")
     (license license:expat))) ; MIT license
 
+(define-public waybar-cpu-histogram
+  (package
+    (name "waybar-cpu-histogram")
+    (version "0.4.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~plattfot/waybar-cpu-histogram")
+             (commit (string-append version))))
+       (sha256
+        (base32
+         "001pyf1jdmf2478plnggd7dkfi688qwi89db2jwfp4zza3640na6"))
+       (file-name (git-file-name name version))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list jsoncpp
+           fmt))
+    (synopsis "CPU histogram for waybar")
+    (description
+     "Custom module for waybar to show CPU usage as a histogram.  A compact way
+to see how many cores are active, compared to having a bar for each
+core/thread.")
+    (home-page "https://github.com/plattfot/cpu-histogram/")
+    (license license:expat)))
+
 (define-public wlr-randr
   (package
     (name "wlr-randr")