summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-01-07 19:18:23 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-01-07 19:25:25 +0800
commit5babdbdd4a2a80a81e0b41c5c3b5b8ccd24652ea (patch)
treea23c690356cc6d08a974b1aa3a0d7e2883c1ea68 /gnu/packages/wm.scm
parentd5909136b8ea2fa7cd609c07a81f92bd37b6819f (diff)
downloadguix-5babdbdd4a2a80a81e0b41c5c3b5b8ccd24652ea.tar.gz
gnu: wlroots: Propagate wayland-protocols.
It's listed in the 'Requires.private' field of wlroots.pc.

* gnu/packages/wm.scm (wlroots) [native-inputs]: Move wayland-protocols ...
[propagated-inputs]: ... to here.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fbbb975a58..9b178ae98d 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1378,12 +1378,12 @@ functionality to display information about the most commonly used services.")
        ("mesa" ,mesa)
        ("pixman" ,pixman)
        ("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)
        ("xcb-util-errors" ,xcb-util-errors)
        ("xcb-util-wm" ,xcb-util-wm)
        ("xorg-server-xwayland" ,xorg-server-xwayland)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("wayland-protocols" ,wayland-protocols)))
+     `(("pkg-config" ,pkg-config)))
     (home-page "https://github.com/swaywm/wlroots")
     (synopsis "Pluggable, composable, unopinionated modules for building a
 Wayland compositor")