summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorSeerLite <seerlite@disroot.org>2023-03-07 00:44:57 -0300
committerLudovic Courtès <ludo@gnu.org>2023-06-09 22:59:20 +0200
commita863b5de8db16e99c73a84ed150c98b1df5ae5dd (patch)
tree72af54ad6c5eb79b81947b39a2f4fde9854ad267 /gnu/packages/wm.scm
parent125978619469a941272ba2f49251a415f86c2b5d (diff)
downloadguix-a863b5de8db16e99c73a84ed150c98b1df5ae5dd.tar.gz
gnu: i3-wm: Use new package style.
* gnu/packages/wm.scm (i3-wm)[arguments]: Use gexps.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7f5e10b60d..729fc7a34a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -331,20 +331,19 @@ commands would.")
                 "0jrya4rhh46sivlmqaqc4n9abpp1yn1ajhi616gn75cxwl8rjqr8"))))
     (build-system meson-build-system)
     (arguments
-     `(;; The test suite requires the unpackaged Xephyr X server.
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'patch-session-file
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (i3 (string-append out "/bin/i3"))
-                    (i3-with-shmlog (string-append out "/bin/i3-with-shmlog")))
-               (substitute* (string-append out "/share/xsessions/i3.desktop")
-                 (("Exec=i3") (string-append "Exec=" i3)))
-               (substitute* (string-append out "/share/xsessions/i3-with-shmlog.desktop")
-                 (("Exec=i3-with-shmlog") (string-append "Exec=" i3-with-shmlog)))
-               #t))))))
+     (list
+      ;; The test suite requires the unpackaged Xephyr X server.
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'patch-session-file
+            (lambda _
+              (let* ((i3 (string-append #$output "/bin/i3"))
+                     (i3-with-shmlog (string-append #$output "/bin/i3-with-shmlog")))
+                (substitute* (string-append #$output "/share/xsessions/i3.desktop")
+                  (("Exec=i3") (string-append "Exec=" i3)))
+                (substitute* (string-append #$output "/share/xsessions/i3-with-shmlog.desktop")
+                  (("Exec=i3-with-shmlog") (string-append "Exec=" i3-with-shmlog)))))))))
     (inputs
      (list libxcb
            xcb-util