summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-11-30 14:38:06 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-30 14:38:06 +0100
commitfba3e9e28f253f54269e0e36af5a75d99f74dd26 (patch)
tree78936b8489255c311c177c35923fd4e5084e5fa5 /gnu/packages/wm.scm
parent680102aa2d5512ce717072de0e59a65474034a48 (diff)
downloadguix-fba3e9e28f253f54269e0e36af5a75d99f74dd26.tar.gz
gnu: Add sbcl-stumpwm-cpu.
* gnu/packages/wm.scm (sbcl-stumpwm-cpu): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3b0205c0be..fceee8e6f3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1910,6 +1910,24 @@ between windows.")
 layouts in StumpWM.")
     (license license:gpl3+)))
 
+(define-public sbcl-stumpwm-cpu
+  (package
+    (inherit stumpwm-contrib)
+    (name "sbcl-stumpwm-cpu")
+    (arguments
+     '(#:asd-systems '("cpu")
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "modeline/cpu"))))))
+    (home-page
+     "https://github.com/stumpwm/stumpwm-contrib/tree/master/modeline/cpu")
+    (synopsis "Modeline support for CPU info")
+    (description "Modeline support for CPU info.")
+    (license license:gpl3+)))
+
 (define-public lemonbar
   (let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
         (revision "1"))