summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 16:28:11 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 19:47:28 +0100
commit205df739400ee08da4ad72c91b082516ecbfa394 (patch)
treec609a4beb486f9a23280ae918c90148d950755e9 /gnu/packages/wm.scm
parent2fe29c8490ec2fec6c87f68df657d57998cc59c2 (diff)
downloadguix-205df739400ee08da4ad72c91b082516ecbfa394.tar.gz
gnu: Move libconfuse to (gnu packages textutils).
* gnu/packages/wm.scm (libconfuse): Move…
* gnu/packages/textutils.scm (libconfuse): …to here.
Adjust all imports.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm23
1 files changed, 1 insertions, 22 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4a6fc62069..abd51f6589 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -83,31 +83,10 @@
   #:use-module (gnu packages video)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages man)
+  #:use-module (gnu packages textutils)
   #:use-module (guix download)
   #:use-module (guix git-download))
 
-(define-public libconfuse
-  (package
-    (name "libconfuse")
-    (version "3.2.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/martinh/libconfuse/"
-                                  "releases/download/v" version
-                                  "/confuse-" version ".tar.xz"))
-              (sha256
-               (base32
-                "02r1mmzik2m0iigbc2da3y754vj24i18r3ml5p2wzs027mjhn959"))))
-    (build-system gnu-build-system)
-    (home-page "https://github.com/martinh/libconfuse")
-    (synopsis "Configuration file parser library")
-    (description "libconfuse is a configuration file parser library.  It
-supports sections and (lists of) values (strings, integers, floats, booleans
-or other sections), as well as some other features (such as
-single/double-quoted strings, environment variable expansion, functions and
-nested include statements).")
-    (license license:isc)))
-
 (define-public bspwm
   (package
     (name "bspwm")