summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-11 20:22:00 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-11 20:28:41 +0100
commitb0805973cd1c08fe031bfed312e570697a665494 (patch)
treed95229d520ccfefa36eeb5395ffe115da2dcd1ea /gnu/packages/wm.scm
parent06ae5efcf385312faec3e6280786bc7b4aa63978 (diff)
downloadguix-b0805973cd1c08fe031bfed312e570697a665494.tar.gz
gnu: Add swaylock.
* gnu/packages/wm.scm (swaylock): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fe4e0f404f..27848ea161 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1221,3 +1221,33 @@ modules for building a Wayland compositor.")
     (synopsis "Idle management daemon for Wayland compositors")
     (description "Swayidle is a idle management daemon for Wayland compositors.")
     (license license:expat))) ; MIT license
+
+(define-public swaylock
+  (package
+    (name "swaylock")
+    (version "1.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/swaywm/swaylock.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "093nv1y9wyg48rfxhd36qdljjry57v1vkzrlc38mkf6zvsq8j7wb"))))
+    (build-system meson-build-system)
+    (inputs `(("cairo" ,cairo)
+              ("gdk-pixbuf" ,gdk-pixbuf)
+              ("libxkbcommon" ,libxkbcommon)
+              ;("linux-pam" ,linux-pam) ; FIXME: Doesn't work.
+              ("wayland" ,wayland)))
+    (native-inputs `(
+                     ("git" ,git)
+                     ("pango" ,pango)
+                     ("pkg-config" ,pkg-config)
+                     ("scdoc" ,scdoc)
+                     ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://github.com/swaywm/sway")
+    (synopsis "Screen locking utility for Wayland compositors")
+    (description "Swaylock is a screen locking utility for Wayland compositors.")
+    (license license:expat))) ; MIT license