summary refs log tree commit diff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-20 18:33:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-20 18:33:30 +0200
commit6f9ba4c91c096a2fb95da111be0657d99ef2b683 (patch)
tree2dda9824a95cfeb3ecee411dd7e7e6dc1c7bf383 /gnu/packages/wxwidgets.scm
parent36e17ab417078710939771d5ab19976eec257309 (diff)
downloadguix-6f9ba4c91c096a2fb95da111be0657d99ef2b683.tar.gz
gnu: Remove wxwidgets@2.8.
* gnu/packages/wxwidgets.scm (wxwidgets@2.8): Remove variable.
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index ea0a2897f7..077195cca7 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -89,34 +89,6 @@ a graphical user interface.  It has language bindings for Python, Perl, Ruby
 and many other languages.")
     (license (list l:lgpl2.0+ (l:fsf-free "file://doc/license.txt")))))
 
-(define-public wxwidgets-2
-  (package
-    (inherit wxwidgets)
-    (version "2.8.12")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/wxWidgets/wxWidgets/"
-                           "releases/download/v" version
-                           "/wxGTK-" version ".tar.gz"))
-       (sha256
-        (base32 "1gjs9vfga60mk4j4ngiwsk9h6c7j22pw26m3asxr1jwvqbr8kkqk"))))
-    (inputs
-     `(("gtk" ,gtk+-2)
-       ("libjpeg" ,libjpeg)
-       ("libtiff" ,libtiff)
-       ("libmspack" ,libmspack)
-       ("sdl" ,sdl)
-       ("unixodbc" ,unixodbc)))
-    (arguments
-     `(#:configure-flags
-       '("--enable-unicode" "--with-regex=sys" "--with-sdl")
-       #:make-flags
-       (list (string-append "LDFLAGS=-Wl,-rpath="
-                            (assoc-ref %outputs "out") "/lib"))
-       ;; No 'check' target.
-       #:tests? #f))))
-
 (define-public wxwidgets-gtk2
   (package (inherit wxwidgets)
            (inputs `(("gtk+" ,gtk+-2)