summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-11 22:58:11 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-11 22:58:11 +0100
commit41c6e4f2b40f41cdbf4e8c7ade29845709f9cdf4 (patch)
treef496dcc2b11819f691cfe6063c52894f2ca76823 /gnu/packages/xdisorg.scm
parent4510aeb91ce6267a14c9cead768869553b3a2279 (diff)
parent58363ee50096fd02743ff6d62ee1125fc440625f (diff)
downloadguix-41c6e4f2b40f41cdbf4e8c7ade29845709f9cdf4.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm113
1 files changed, 113 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9882f4a723..d62bab482a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -33,6 +33,7 @@
 ;;; Copyright © 2020 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Ivan Vilata i Balaguer <ivan@selidor.net>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Damien Cassou <damien@cassou.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2117,3 +2118,115 @@ font and theme settings when a complete desktop environment (GNOME, KDE) is
 not running.  With a simple @file{.xsettingsd} configuration file one can avoid
 configuring visual settings in different UI toolkits separately.")
     (license license:bsd-3)))
+
+(define-public clipnotify
+  (package
+    (name "clipnotify")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cdown/clipnotify.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1v3ydm5ljy8z1savmdxrjyx7a5bm5013rzw80frp3qbbjaci0wbg"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out  (assoc-ref outputs "out"))
+                    (bin  (string-append out "/bin"))
+                    (doc  (string-append %output "/share/doc/" ,name "-" ,version)))
+               (install-file "clipnotify" bin)
+               (install-file "README.md" doc)
+               #t))))
+       #:make-flags (list "CC=gcc")
+       #:tests? #f))
+    (inputs
+     `(("libx11" ,libx11)
+       ("libXfixes" ,libxfixes)))
+    (home-page "https://github.com/cdown/clipnotify")
+    (synopsis "Notify on new X clipboard events")
+    (description "@command{clipnotify} is a simple program that, using the
+XFIXES extension to X11, waits until a new selection is available and then
+exits.
+
+It was primarily designed for clipmenu, to avoid polling for new selections.
+
+@command{clipnotify} doesn't try to print anything about the contents of the
+selection, it just exits when it changes.  This is intentional -- X11's
+selection API is verging on the insane, and there are plenty of others who
+have already lost their sanity to bring us xclip/xsel/etc.  Use one of those
+tools to complement clipnotify.")
+    (license license:public-domain)))
+
+(define-public clipmenu
+  (let ((commit "a495bcc7a4ab125182a661c5808364f66938a87c")
+        (revision "1"))
+    (package
+     (name "clipmenu")
+     (version (string-append "5.6.0-"
+                             revision "." (string-take commit 7)))
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/cdown/clipnotify.git")
+              (commit commit)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "12vvircdhl4psqi51cnfd6bqy85v2vwfcmdq1mimjgng727nwzys"))))
+     (build-system gnu-build-system)
+     (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-hardcoded-paths
+           (lambda _
+             (substitute* "clipmenud"
+               (("has_clipnotify=0")
+                "has_clipnotify=1")
+               (("command -v clipnotify >/dev/null 2>&1 && has_clipnotify=1")
+                "")
+               (("clipnotify \\|\\| .*")
+                (string-append (which "clipnotify") "\n"))
+               (("xsel --logfile")
+                (string-append (which "xsel") " --logfile")))
+             (substitute* "clipmenu"
+               (("xsel --logfile")
+                (string-append (which "xsel") " --logfile")))
+             #t))
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out  (assoc-ref outputs "out"))
+                    (bin  (string-append out "/bin"))
+                    (doc  (string-append %output "/share/doc/"
+                                         ,name "-" ,version)))
+               (install-file "clipdel" bin)
+               (install-file "clipmenu" bin)
+               (install-file "clipmenud" bin)
+               (install-file "README.md" doc)
+               #t))))
+       #:tests? #f))
+     (inputs
+      `(("clipnotify" ,clipnotify)
+        ("xsel" ,xsel)))
+     (home-page "https://github.com/cdown/clipmenu")
+     (synopsis "Simple clipboard manager using dmenu or rofi and xsel")
+     (description "Start @command{clipmenud}, then run @command{clipmenu} to
+select something to put on the clipboard.
+
+When @command{clipmenud} detects changes to the clipboard contents, it writes
+them out to the cache directory.  @command{clipmenu} reads the cache directory
+to find all available clips and launches @command{dmenu} (or @command{rofi},
+depending on the value of @code{CM_LAUNCHER}) to let the user select a clip.
+After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
+     (license license:public-domain))))