summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-04-09 21:46:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-02 03:00:03 +0200
commit9c44af6bd67579ef0d916ecf23fe832c9d17802f (patch)
tree0ad4adeacaefb7c56d19969f09d0008e1fa8c594 /gnu/packages/xdisorg.scm
parenteb305784bfa229043d53ce60c130e25b07e1447f (diff)
downloadguix-9c44af6bd67579ef0d916ecf23fe832c9d17802f.tar.gz
gnu: Replace hard-coded "CC=gcc" with CC-FOR-TARGET calls.
* gnu/packages/admin.scm (cbatticon)[arguments]<#:make-flags>: Use
CC-FOR-TARGET.
* gnu/packages/assembly.scm (dev86)[arguments]<#:make-flags>: Likewise.
* gnu/packages/cdrom.scm (cd-discid)[arguments]<#:make-flags>: Likewise.
* gnu/packages/crypto.scm (signify, keyutils, ssss, libscrypt, enchive)
[arguments]<#:make-flags>: Likewise.
* gnu/packages/emacs-xyz.scm (emacs-emacsql, emacs-telega)[arguments]
<#:phases>: Likewise.
* gnu/packages/gnupg.scm (pgpdump)[arguments]<#:make-flags>: Likewise.
* gnu/packages/image-viewers.scm (feh, imv)[arguments]<#:make-flags>:
Likewise.
* gnu/packages/image.scm (libjxr, giflib, freeimage)[arguments]
<#:make-flags>: Likewise.
* gnu/packages/irc.scm (ii, sic)[arguments]<#:make-flags>: Likewise.
* gnu/packages/lua.scm (make-lua-expat, make-lua-ossl, make-lua-sec)
(make-lua-cqueues, make-lua-lgi, lua-resty-signal)[arguments]
<#:make-flags>: Likewise.
* gnu/packages/networking.scm (httping, pixiewps, sslh, nethogs, spiped)
(can-utils, hcxtools, batctl)[arguments]<#:make-flags>: Likewise.
* gnu/packages/pdf.scm (fbida)[arguments]<#:make-flags>: Likewise.
* gnu/packages/ssh.scm (endlessh)[arguments]<#:make-flags>: Likewise.
* gnu/packages/toys.scm (nyancat)[arguments]<#:make-flags>: Likewise.
* gnu/packages/upnp.scm (miniupnpc)[arguments]<#:make-flags>: Likewise.
* gnu/packages/xdisorg.scm (bemenu, xbanish, sxhkd, xcape, xssproxy)
(xrandr-invert-colors, hsetroot, xsettingsd)[arguments]<#:make-flags>:
Likewise.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 418fe73fdc..15c5377a3d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -269,8 +269,8 @@ used to further tweak the behaviour of the different profiles.")
         (base32 "1fjcs9d3533ay3nz79cx3c0lmy2chgragr2lhsy0xl2ckr0iins0"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f
-       #:make-flags (list "CC=gcc"
+     `(#:tests? #f
+       #:make-flags (list ,(string-append "CC=" (cc-for-target))
                           "CFLAGS=-O2 -fPIC"
                           (string-append "LDFLAGS=-Wl,-rpath="
                                          (assoc-ref %outputs "out") "/lib")
@@ -892,7 +892,7 @@ to find buttons, etc, on the screen to click on.")
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
-       #:make-flags (list "CC=gcc"
+       #:make-flags (list ,(string-append "CC=" (cc-for-target))
                           (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases (modify-phases %standard-phases
                   (delete 'configure)))) ; no configure script
@@ -1071,7 +1071,7 @@ Guile will work for XBindKeys.")
      `(#:phases (modify-phases %standard-phases (delete 'configure))
        #:tests? #f  ; no check target
        #:make-flags
-       (list "CC=gcc"
+       (list ,(string-append "CC=" (cc-for-target))
              (string-append "PREFIX=" %output)
              ;; Keep the documentation where the build system installs LICENSE.
              (string-append "DOCPREFIX=" %output
@@ -1184,7 +1184,7 @@ within a single process.")
        #:phases (modify-phases %standard-phases (delete 'configure))
        #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
                           "MANDIR=/share/man/man1"
-                          "CC=gcc")))
+                          ,(string-append "CC=" (cc-for-target)))))
     (inputs
      `(("libxtst" ,libxtst)
        ("libx11" ,libx11)))
@@ -1553,7 +1553,7 @@ demos.  It also acts as a nice screen locker.")
     (arguments `(#:make-flags `("bindir=/bin"
                                 "man1dir=/share/man/man1"
                                 ,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
-                                "CC=gcc")
+                                ,,(string-append "CC=" (cc-for-target)))
                  #:phases (modify-phases %standard-phases
                             (delete 'configure)
                             (delete 'check))))
@@ -2102,7 +2102,7 @@ to automatically turn it on on login.")
                 "1br3x9vr6xm4ika06n8cfxx1b3wdchdqvyzjl4y1chmivrml8x9h"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list "CC=gcc")
+     `(#:make-flags (list ,(string-append "CC=" (cc-for-target)))
        #:tests? #f ; there are none
        #:phases
        (modify-phases %standard-phases
@@ -2407,7 +2407,7 @@ Xwrits hides itself until you should take another break.")
     (arguments
      `(#:scons ,scons-python2
        #:scons-flags
-       (list "CC=gcc")
+       (list ,(string-append "CC=" (cc-for-target)))
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'patch-sconstruct
@@ -2762,7 +2762,7 @@ and execute @file{.desktop} files of the Application type.")
      `(#:tests? #f
        #:make-flags
        (list
-        "CC=gcc"
+        ,(string-append "CC=" (cc-for-target))
         (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases