summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-03 14:55:47 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-03 14:58:34 +0100
commit95bf2fb637ba4abb27efe94e0b671c1e93204e4f (patch)
tree2faf79a8a330ba9e2f0f34b1b4cb8e5d998748d4 /gnu/packages/xdisorg.scm
parentdf147c4fdb5af833bc65fb924abc964059dfa319 (diff)
downloadguix-95bf2fb637ba4abb27efe94e0b671c1e93204e4f.tar.gz
gnu: Add wl-clipboard.
* gnu/packages/xdisorg.scm (wl-clipboard): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index dc729229f3..90383e45af 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -22,7 +22,7 @@
 ;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
 ;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
-;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
 ;;;
@@ -62,6 +62,7 @@
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -1612,3 +1613,28 @@ colors on all monitors attached to an XRandR-capable X11 display server.")
     (description "@code{sct} is a lightweight utility to set the color
 temperature of the screen.")
     (license license:bsd-3)))
+
+(define-public wl-clipboard
+  (package
+    (name "wl-clipboard")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/bugaevc/wl-clipboard.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03h6ajcc30w6928bkd4h6xfj4iy2359ww6hdlybq8mr1zwmb2h0q"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://github.com/bugaevc/wl-clipboard")
+    (synopsis "Command-line copy/paste utilities for Wayland")
+    (description "Wl-clipboard is a set of command-line copy/paste utilities for
+Wayland.")
+    (license license:gpl3+)))