summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2021-07-13 16:57:48 +0000
committerLudovic Courtès <ludo@gnu.org>2021-07-31 11:30:41 +0200
commit554e09254c3b8ab68e96843d2de79db19fabfbce (patch)
tree52811555be5a33d9d4e3dc11c7d7839e796b1db0 /gnu/packages/xdisorg.scm
parentf8458a228224942298e0967a099f872c13713ede (diff)
downloadguix-554e09254c3b8ab68e96843d2de79db19fabfbce.tar.gz
gnu: libdrm: Update to 2.4.107.
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
libpciaccess to a propagated input as the pkg-config for libdrm_intel now
includes it in the libs.
[arguments]: Add conditional testing support to the replacement for the
standard check phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d13392ae77..6963cad8f1 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@ rasterisation.")
 (define-public libdrm
   (package
     (name "libdrm")
-    (version "2.4.104")
+    (version "2.4.107")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -646,7 +646,7 @@ rasterisation.")
                     version ".tar.xz"))
               (sha256
                (base32
-                "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+                "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -661,9 +661,10 @@ rasterisation.")
 
        #:phases (modify-phases %standard-phases
                   (replace 'check
-                    (lambda _
-                      (invoke "meson" "test" "--timeout-multiplier" "5"))))))
-    (inputs
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+    (propagated-inputs
      `(("libpciaccess" ,libpciaccess)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))