summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-05-19 22:21:50 +0800
committer宋文武 <iyzsong@gmail.com>2015-05-19 22:28:15 +0800
commitd692678fee97c97e7e4d2d616e5d11e2f0af1a8b (patch)
tree9876bf6f8e1da31ca756e6dd257bde3d59cb1133 /gnu/packages/xfce.scm
parent38d27786086ff2b8d1325b1c0090ccff3745adfc (diff)
downloadguix-d692678fee97c97e7e4d2d616e5d11e2f0af1a8b.tar.gz
gnu: Add xfce4-clipman-plugin.
* gnu/packages/xfce.scm (xfce4-clipman-plugin): New variable.
  (xfce)[propagated-inputs]: Add it.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 37f09579fe..818941892f 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -318,6 +318,37 @@ applications menu, workspace switcher and more.")
     ;; to read the battery state via ACPI or APM are covered by lgpl2.0+.
     (license (list gpl2+ lgpl2.0+))))
 
+(define-public xfce4-clipman-plugin
+  (package
+    (name "xfce4-clipman-plugin")
+    (version "1.2.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "19a8gwcqc0r5qqi8w28dc8arqip34m8yxdb87lgps9g5qfcky113"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("exo" ,exo)
+       ("libxfce4ui" ,libxfce4ui)
+       ("libxtst" ,libxtst)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin")
+    (synopsis "Clipboard manager for Xfce")
+    (description
+     "Clipman is a clipboard manager for Xfce.  It keeps the clipboard contents
+around while it is usually lost when you close an application.  It is able to
+handle text and images, and has a feature to execute actions on specific text by
+matching them against regular expressions.")
+    (license (list gpl2+))))
+
 (define-public xfce4-appfinder
   (package
     (name "xfce4-appfinder")
@@ -601,6 +632,7 @@ on your desktop.")
        ("tumlber"              ,tumbler)
        ("xfce4-appfinder"      ,xfce4-appfinder)
        ("xfce4-battery-plugin" ,xfce4-battery-plugin)
+       ("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
        ("xfce4-panel"          ,xfce4-panel)
        ("xfce4-session"        ,xfce4-session)
        ("xfce4-settings"       ,xfce4-settings)