summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:21 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:26:32 +0200
commitf800291e0809ab477e07df4fbd23216d451d8c58 (patch)
treeccf57cdfb8e5dbe92ca8785c5dfa3773d0d52ce5 /gnu/packages/xfce.scm
parent0c34b9494333fb355d288a0165b85cb3c1c2a628 (diff)
downloadguix-f800291e0809ab477e07df4fbd23216d451d8c58.tar.gz
gnu: Add xfce4-wavelan-plugin.
* gnu/packages/xfce.scm (xfce4-wavelan-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d8f67374fa..13d16def99 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1229,3 +1229,30 @@ A plugin for the Xfce panel is also available.")
      "This is a volume keys control daemon for Xfce Desktop environment. It controls
  the volume using multimedia keys. It also provides volume change notifications.")
     (license gpl3+)))
+
+(define-public xfce4-wavelan-plugin
+  (package
+   (name "xfce4-wavelan-plugin")
+   (version "0.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-wavelan-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-wavelan-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "05zdiq1igr1fcvnwlivg8g3szvxmlr3yc7jfj3bwgqrs0vm827zl"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin")
+    (synopsis "Show stats from WLAN interface in Xfce panel")
+    (description "This plugin is used to display stats from a wireless
+lan interface (signal state, signal quality, network name (SSID)).")
+    (license bsd-2)))