summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-21 19:30:30 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-01-29 09:16:46 +0800
commitd824836e860847ade7de47b179085c9a64bc4abe (patch)
tree5f65e09c4339704533fa2e33a7cd3476aee00582 /gnu/packages/xfce.scm
parent29ec1a4bb74e6374491699806068f4422d6e3041 (diff)
downloadguix-d824836e860847ade7de47b179085c9a64bc4abe.tar.gz
gnu: Add thunar-shares-plugin.
* gnu/packages/xfce.scm (thunar-shares-plugin): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 8159010361..43dbbfdf43 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -802,6 +802,28 @@ and import the new pictures from your camera.")
 archive files using the file context menus in the Thunar file manager.")
     (license gpl2+)))
 
+(define-public thunar-shares-plugin
+  (package
+    (name "thunar-shares-plugin")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://archive.xfce.org/src/thunar-plugins/"
+                           name "/" (version-major+minor version)
+                           "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "01rzmjj673sjhzkdh24d8bha57dbahycb44hlr4zld0mr7kda28h"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config intltool))
+    (inputs (list thunar gtk+))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Folder share plugin for Thunar file manager")
+    (description
+     "The Thunar Shares Plugin allows you to quickly share a folder using
+Samba from Thunar (the Xfce file manager) without requiring root access.")
+    (license gpl2+)))
+
 (define-public xfwm4
   (package
     (name "xfwm4")