summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:08:36 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:01:40 +0800
commit62ac2ed9f42e3dc543e2cb2386666ebac4e41922 (patch)
tree2f4e2018ddcf0815f90fb82ecb7de1d9789a04f9 /gnu/packages/xfce.scm
parent180e33e3f2b082a4aae8723658d539cb97210692 (diff)
downloadguix-62ac2ed9f42e3dc543e2cb2386666ebac4e41922.tar.gz
gnu: Add gtk-xfce-engine.
* gnu/packages/xfce.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
new file mode 100644
index 0000000000..696fffe8ea
--- /dev/null
+++ b/gnu/packages/xfce.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages xfce)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk))
+
+(define-public gtk-xfce-engine
+  (package
+    (name "gtk-xfce-engine")
+    (version "3.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "13c3ajfqkdr6jlqjyhcp4nls0ddanypr83q9qib2ciffik78zq4h"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (inputs `(("gtk+" ,gtk+-2)))
+    (home-page "http://www.xfce.org/")
+    (synopsis "GTK+ theme engine for Xfce")
+    (description
+     "Default GTK+ engine and themes for Xfce Desktop Environment.")
+    (license gpl2+)))