summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:32:04 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:35:25 +0800
commit3b3a7fe78ca1336ad0130eefaf2f01e5a7352a0e (patch)
treee79fc2ca2fc5b5a781c5c2ea3cca5894b2bd36c2 /gnu/packages/xfce.scm
parent305bc4cca8e76cba32cea147e91f33768a8f1ca6 (diff)
downloadguix-3b3a7fe78ca1336ad0130eefaf2f01e5a7352a0e.tar.gz
gnu: Add xfce4-panel.
* gnu/packages/xfce.scm (xfce4-panel): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index e6dc4c3b58..ceceba65f8 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -233,3 +233,34 @@ merging features essential for loading menus modified with menu editors.")
 various URI schemes and MIME types.  It is an implementation of the thumbnail
 management D-Bus specification.")
     (license gpl2+)))
+
+(define-public xfce4-panel
+  (package
+    (name "xfce4-panel")
+    (version "4.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/xfce/"
+                                  (version-major+minor version)
+                                  "/src/" name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1f8903nx6ivzircl8d8s9zna4vjgfy0qhjk5d2x19g9bmycgj89k"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (propagated-inputs
+     `(("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-1.0.pc
+    (inputs
+     `(("exo" ,exo)
+       ("garcon", garcon)
+       ("libwnck" ,libwnck-1)
+       ("libxfce4ui" ,libxfce4ui)))
+    (home-page "http://www.xfce.org/")
+    (synopsis "Xfce desktop panel")
+    (description
+     "Desktop panel for Xfce, which contains program launchers, window buttons,
+applications menu, workspace switcher and more.")
+    ;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
+    (license (list gpl2+ lgpl2.1+))))