summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorKei Yamashita <kei@openmailbox.org>2016-04-25 17:33:06 -0400
committer宋文武 <iyzsong@gmail.com>2016-04-26 09:25:03 +0800
commitf674439433da47efd7253b59dbd27641c3aa6fbc (patch)
tree3330d0238a7fed13e37cacdb5fcada5ee9a26d9a /gnu/packages/xfce.scm
parentf79ee25f32e9eb165e34c8748a93006205d87f94 (diff)
downloadguix-f674439433da47efd7253b59dbd27641c3aa6fbc.tar.gz
gnu: Add xfce4-taskmanager.
* gnu/packages/xfce.scm (xfce4-taskmanager): Add variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bd4992eb02..c164c66a18 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -789,3 +789,29 @@ and scroll through images.  It can be used to run a slideshow of images, open
 images with other applications like an image-editor or configure an image as
 the desktop wallpaper.")
     (license gpl2+)))
+
+(define-public xfce4-taskmanager
+  (package
+    (name "xfce4-taskmanager")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/apps/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1jwywmkkkmz7406m1jq40w6apiav25cznafhigbgpjv6z5hv27if"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libwnck" ,libwnck-2)
+       ("gtk+" ,gtk+-2)))
+    (home-page "http://goodies.xfce.org/projects/applications/xfce4-taskmanager")
+    (synopsis "Easy to use task manager")
+    (description
+     "This is a task manager for the Xfce desktop.  It displays the CPU and
+memory usage graphically, and it can display processes as a tree.")
+    (license gpl2+)))