summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:34 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:29:53 +0200
commit2aee1fef0bef7eed58f1c68f8996affa22149b2c (patch)
treef24675e0b63fdcf78a47d1a278a3fc45d96cc0c7 /gnu/packages/xfce.scm
parentfa6a9d9863c111f84eaca3a56af93a3ae2c9bc9a (diff)
downloadguix-2aee1fef0bef7eed58f1c68f8996affa22149b2c.tar.gz
gnu: Add xfce4-fsguard-plugin.
* gnu/packages/xfce.scm (xfce4-fsguard-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d4c2cb701a..5b4ebaf603 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1434,6 +1434,36 @@ or timer.  Combining with Xfce's ability to auto-hide panels can make
 this very convenient.")
     (license gpl2+)))
 
+(define-public xfce4-fsguard-plugin
+  (package
+   (name "xfce4-fsguard-plugin")
+   (version "1.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-fsguard-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-fsguard-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "05nmfkrmifm76bsywqmbjd1qdvzagv5cbvnwbkb57156j055vl6n"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-fsguard-plugin")
+    (synopsis "Xfce panel plugin to monitor free disk space")
+    (description "The panel plugin checks free space on a chosen mount
+point frequently and displays a message when a limit is reached.  There
+are two limits: a warning limit where only the icon changes, and an
+urgent limit that advise the user with a message.  The icon button can
+be clicked to open the chosen mount point.")
+    (license bsd-2)))
+
 (define-public xfce4-mount-plugin
   (package
    (name "xfce4-mount-plugin")