summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:21:53 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:16:22 +0800
commit2eb7d77d48a6fb452021d456fe18d5acd24ba9ec (patch)
tree5b76ec880490adf20226aed4713ae2790244c54a /gnu/packages/xfce.scm
parent6cec9818dbea00aeb7b6be308d6f8d16fd75611a (diff)
downloadguix-2eb7d77d48a6fb452021d456fe18d5acd24ba9ec.tar.gz
gnu: Add exo.
* gnu/packages/xfce.scm (exo): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5cd5f22c25..bd2770dab9 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -26,7 +26,8 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages xorg)
-  #:use-module (gnu packages xdisorg))
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages web))
 
 (define-public gtk-xfce-engine
   (package
@@ -134,3 +135,34 @@ storage system.")
      "Libxfce4ui is the replacement of the old libxfcegui4 library.  It is used
 to share commonly used Xfce widgets amoung the Xfce applications.")
     (license lgpl2.0+)))
+
+(define-public exo
+  (package
+    (name "exo")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1c05pbagw14djv5zmqg34qfj40jav8sd10w2zi2wpzrad4qal8bf"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)))
+    (propagated-inputs
+     ;; exo-1.pc refers to all these.
+     `(("gtk+" ,gtk+-2)
+       ("libxfce4util" ,libxfce4util)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("perl-uri" ,perl-uri)))
+    (home-page "http://www.xfce.org/")
+    (synopsis "Extension library for Xfce")
+    (description
+     "An extension library to Xfce.  While Xfce comes with quite a few libraries
+that are targeted at desktop development, libexo is targeted at application
+development.")
+    ;; Libraries are under LGPLv2+, and programs under GPLv2+.
+    (license (list gpl2+ lgpl2.1+))))