summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-23 04:52:29 +0800
committerLudovic Courtès <ludo@gnu.org>2022-03-25 12:21:23 +0100
commit1f46534646b199699a8c4d33eccf8f19af7ee8ff (patch)
tree657b43f59a516a0a05e9ccdcf9b387ec187c6fbc /gnu/packages/xfce.scm
parentf2bbe73b817f2dc5a3ca866a750ce71737c12de2 (diff)
downloadguix-1f46534646b199699a8c4d33eccf8f19af7ee8ff.tar.gz
gnu: Add gigolo.
* gnu/packages/xfce.scm (gigolo): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index cdd98f2863..a2d8e99290 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -881,6 +881,29 @@ optional application menu or icons for minimized applications or launchers,
 devices and folders.")
     (license gpl2+)))
 
+(define-public gigolo
+  (package
+    (name "gigolo")
+    (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/"
+                                  name "/" (version-major+minor version)
+                                  "/" name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1hxv3lla567nnqxxly8xfi8fzmpcdhxb493x9hinr7szfnh1ljp3"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config intltool))
+    (inputs (list gtk+))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Manage connections to remote file systems")
+    (description
+     "Gigolo is a graphical user interface to easily manage connections to
+remote file systems using GIO/GVfs.  It allows you to quickly connect/mount
+local and remote file systems and manage bookmarks of such.")
+    (license gpl2)))                              ;version 2 only
+
 (define-public xfce4-terminal
   (package
     (name "xfce4-terminal")