summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-03-02 20:37:21 +0800
committer宋文武 <iyzsong@gmail.com>2015-03-02 20:37:21 +0800
commitb28367995180af9eadae0af1fac7a138cf8b2c52 (patch)
tree8b16489c0942282bea08d02b9433fcef4ad07390 /gnu/packages/xfce.scm
parentd57e6d0f8ef6014528b0fcfd3f900c16065d1960 (diff)
downloadguix-b28367995180af9eadae0af1fac7a138cf8b2c52.tar.gz
gnu: xfconf: Re-enable tests.
* gnu/packages/xfce.scm (xfconf)[arguments]: Add #:phases.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 8ad2742545..08d7949b68 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -99,8 +99,18 @@ Xfce Desktop Environment.")
                (base32
                 "0mmi0g30aln3x98y5p507g17pipq0dj0bwypshan8cq5hkmfl44r"))))
     (build-system gnu-build-system)
-    (arguments '(#:tests? #f  ; XXX test suite requires working DBus
-                 #:parallel-tests? #f)) ; parallel tests failed
+    (arguments
+     '(#:phases
+       ;; Run check after install phase to test dbus activation.
+       (alist-cons-after
+        'install 'check
+        (lambda _
+          (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
+          ;; Run test-suite under a dbus session.
+          (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
+                  (string-append %output "/share"))
+          (zero? (system* "dbus-launch" "make" "check")))
+        (alist-delete 'check %standard-phases))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))