summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:31 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:28:48 +0200
commit2f81e67850502394d17ac7e74d23cdf8ee215516 (patch)
tree73634bc50efdc14b411eff4647df41a6ada5f4fe /gnu/packages/xfce.scm
parentc8417d327ab52c53bc08391c72f0017bed2e83e8 (diff)
downloadguix-2f81e67850502394d17ac7e74d23cdf8ee215516.tar.gz
gnu: Add xfce4-calculator-plugin.
* gnu/packages/xfce.scm (xfce4-calculator-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bfd6542aa0..9aaabe02c6 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1317,6 +1317,34 @@ watch your every step.")
 and a calendar appears when you left-click on it.")
     (license gpl2+)))
 
+(define-public xfce4-calculator-plugin
+  (package
+   (name "xfce4-calculator-plugin")
+   (version "0.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-calculator-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-calculator-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1scx7z5ijg2fpcqrzv1nxhpj9vrqic7pyghig70f2n5hgaaanl3v"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-calculator-plugin")
+    (synopsis "Calculator for the Xfce panel")
+    (description "This plugin is a calculator for the Xfce4 panel.  It
+supports common mathematical operators (+, -, *, /, ^) with usual
+precedence rules, and the following functions and common constants.")
+    (license gpl2+)))
+
 (define-public xfce4-embed-plugin
   (package
    (name "xfce4-embed-plugin")